Send Now and Print Now Tools

The Send Now and Print Now tools allow the user to attach short cut keys on the File menus of the following dialogs.  These short cuts allow the user to quickly email (Send now) or print (Print now) user configured forms or reports.  

Send Now Tool

The Auto Send Now tool enhances the ability to quickly e-mail a document directly from the various documents listed above. The benefit of this feature over the traditional Crystal Reports export is that the system uses the settings within the account record to e-mail the document and records the same date and time settings as the Auto Send process.  

  1. Select the File > Auto Send Options > Send Now tab from the main EBMS menu  to open the follow dialog:

  2. Select the Sales Order Menu Options option by double clicking on a Module Menus record to attach documents to a sales order or invoice. The following Module Menu Settings dialog will open:

  3. Highlight a report and click Properties... to select the form and set email settings.

  4. Configure the following settings for each hot key.

    1. Choose an optional document for one or more hot key options.  For example, select the Invoice (PLAIN PAPER) option by clicking on the Browse button and selecting the invoice document from the reports menu. Review the Reports > Reports Menu section of the Main documentation for more details on locating forms and reports.  Keep Report blank to not include a report attachment.

    2. Some documents have multiple accounts.  For example the sales order contains both a Bill To Contact and a Ship To Contact.  Select the Default Contact to use when sending the email.

    3. Enter the Email Subject and Email Body using HTML or plain text syntax.  The keywords list located at the bottom of the dialog can be used within the e-mail body.  Use the < > brackets between accessible database fields.  Review the database field option within the [Main] Technical > Set Query Options documentation for instructions to access technical database field information.

  5. Open the sales order and invoice dialog and select File from the sales order menu:

  6. Notice that a pair of hot keys are added to the sales order's file menu.  The first set of Send hot keys is used to auto send forms and reports using AutoSend by using Ctrl+#.  AutoSend will open a email, populate the contact info, format the email description and memo, and attach the report.  All done with a quick hot key.   

  7. Click on the To, CC, or BCC buttons to populate contact information from the customer's contact list based on the Select Recipients setting.

  8. Use one of the following Send options to generate and send a report:

    1. The Send button will directly send the e-mail using the SMPT settings.

    2. The Send via Outlook option allows the user to edit the e-mail and send it using MS Outlook.

    3. The Send via Thunderbird option allows the user to edit the e-mail and send it using Thunderbird.

Print Now Tool

The second set of hot keys has a similar effect to print a form without prompts by using the Ctrl + Alt + #.  This is an alternative print method to the File > Print menu on the invoice.  The File > Print menu opens the dialog and the short cut key (Ctrl + Alt + #) does not.  

Review [Main] Reports > Printing a Report for steps to save default prompts for these reports.