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Getting Started 
Technical Support 

Welcome to the instructional manual for the E-Commerce module within the Eagle Business 
Management System (EBMS).  In the sections following, explanations and examples of the 
available features within the E-Commerce Module will be explained.  If you need to reach our 
staff for further help, contact us using the information below: 

 

 

 

 

 

Eagle Business Software 

5351 Lincoln Highway, Suite 9 

Gap, PA 17527 

(717) 442-3247 x2 

(717)-442-1096 fax 

www.EagleBusinessSoftware.com 

Email: Support@EagleBusinessSoftware.com 

 

 

 

 

Manual Revision 7.1.213.162 October 2007 

 

http://www.eaglebusinesssoftware.com/
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Introduction 

The EBMS e-Commerce module is used to display and sell products on a company website.  The 
web store’s product web pages are created within EBMS and are uploaded to the website 
eliminating the need for experienced web programmers.  The module includes a full featured 
shopping card that includes terms, shipping options, and pricing uploaded from the EBMS 
software.  This optional EBMS module facilitates the process of A) Uploading product information, 
customer information, and page design from the EBMS Software and B) manage an online 
shopping cart, and C) downloading orders from the e-commerce website. 

 

 

 

A) Upload information such as product information, customer information, pricing, and 
availability. 

B) Manage the Shopping Cart  

C) Download Orders  

 

The EBMS e-commerce module gives the user the following advantages: 

 Add, remove, and control the content of your entire e-commerce website from 
the EBMS software.   Product pricing, availability, and details are derived from the 

EBMS inventory database.   

 Add entire groups of products in minutes – Products within the EBMS inventory 
catalog can easily be added or removed from the e-commerce store.    

 Update product information, pricing, and availability regularly by a simple click of 
a button.  Products may be removed or marked as out-of-stock based on inventory 
levels. 

 Reduces redundant information – The user is not required to maintain two separate 
product lists; the POS system within EBMS and the e-Commerce list on the web. 
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 Dynamic product information is automatically created – New product lists, 
customer pricing, and Out of stock notations, details are created directly from the 
information within EBMS.  

 User specific pricing, terms, and shipping options are displayed based on the 
user name and password created within EBMS - A customer’s price level, special 
pricing, terms, and shipping information are derived directly the EBMS software. The 
customer’s name and password are entered within the customer record of EBMS. 

 Receive orders directly into your order entry system – E-commerce orders are 
inserted into EBMS as a sales order. 

 Verify credit card information on-line through a common gateway. Credit card 
processing is integrated into the EBMS software.  The card is validated on-line but is not 
debited until invoice is processed.   This feature minimizes the number credits and 
billing charges at the time the order is shipped.  

Review the following sections for detailed instructions on planning your website, Creating 
Inventory Groups, and processing orders. 
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Getting Started 

 

System options must be setup before EBMS can connect to the e-commerce website.   Go to File 
> System Options using the main EBMS menu and click on the Website tab as shown below: 

 

Enter the e-commerce website’s URL into the Website Hostname entry field. 

The EBMS Server option must contain the address of the Windows server that is running the 
EBMS software.     This option is populated only if the orders are automatically downloaded from 
the website to EBMS.     EBMS must be running on a server running Windows Server or Windows 
XP or newer OS to automatically download orders into EBMS.         Orders can be entered into 
EBMS and be printed in the user’s office as soon as the order is placed on the web if the Auto-
insert web orders option is enabled.    

If the orders are manually downloaded to EBMS then select Sales > Download Web Orders 

from the EBMS menu to download orders.    

The Website Username and Website Password must be obtained from the EBMS e-commerce 
server administrator.    This information is required so that EBMS can upload information to the e-
commerce server and download orders from the server.      
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The Autorize.net Login ID, Authorize.net Password, and other Authorize.net settings must be 
set before any credit card processing is done within the EBMS e-commerce shopping cart on the 
web.    These entries will remain blank if no credit card processing is done on the web.   Review 
the Configuring the Shopping Cart > Payment Options section for more details on these settings.   
Instructions to apply for an Authorize.net account are found in the Certifications and Applications 
> Authorize.Net Application section. 

 

Go to Sales > Options > Website to view or set the website options shown below: 

 

The Web Cash Account should be set to the general ledger cash account used for website 
sales.   E-commerce sales paid using a credit card are processed using this cash account. This 
account should be a separate cash account than the one used within the EBMS Sales module.  
Review the Sales > Customer Payments > Cash Accounts section of the main EBMS manual for 
more details on the standard sales cash account. 

Enable the credit card options for each card type that is accepted in the online shopping cart.  
These options must match the credit card merchant accounts listed in the Authorize.net 
configuration.  Review the Processing Credit Cards section for more details on credit card 
processing.  

The Web Customer entry is required for customers who can purchase product on-line without a 
login name or password.      The generic customer id entered in the Web Customer entry is used 
whenever a person submits an order without specifically identifying themselves by logging onto 
the site.          Review the Creating a Generic Customer section for more details on the Web 
Customer setting.    It is important that the terms, shipping options, and other settings within this 
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generic customer are configured before customers place e-commerce orders without a login 
process.  Review the Customer Login section for more details on allowing or requiring customer 
logins.    

The Customer Matching options are used to compare the customer information on an order 
received from a generic customer (customer that has not logged into the system with a user 
name) to the customer database within EBMS.    This allows the order to be entered without 
logging in but matched with the customer using either the E-mail Address or Name and 
Address.    Set this option to None to manually move orders to existing customer records or 
create new customer records.   The Customer Matching option is not implacable if the Web 
Customer entry is blank.  

Enable the Create new customer if no match option if a new customer record should be 
created within EBMS if the Customer Matching criterion does not match an existing record.   
Review the Creating a Generic Customer section for more details on processing orders from the 
generic customer.  

The  Show New Icon... entry identifies the amount of time a new item is listed on a new items 
page of the site or shows a new item star-burst by the new item.     Review the Identifying New 
Products section for more details on this option. 

The EBMS e-commerce module allows the user to setup multiple Web Groups although the 
average e-commerce site will only contain a single Web Group.    Click on the New button if no 
Web Groups exist and enter the group label as shown below: 

 

Click on the OK button to create a new group.  Review the Advanced Features > Multiple Web 

Groups section for more details on multiple groups. 

Click on the Properties button to set additional shopping cart options: 
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All Shipping Methods must be created within EBMS before they can be selected within the web 
group properties.  Select Sales > Options from within the EBMS menu and create the Shipping 
Methods within the General tab. Review the Sales > Freight and Shipping Charges > Creating 
Shipping Methods within the main EBMS documentation for details on Shipping Methods.      

After shipping methods have been created within Sales > Options then click the Add button 
within the Shipping Methods tab of the web group properties.     

 

Select the shipping option and click OK.   Repeat for each shipping method that can be selected 
as an option within the web shopping cart.   Do not include the shipping options that are not 
available for the user to choose for web orders. 
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Click on the Web Confirmation E-mail tab. 

 

The settings within this tab are used to configure the order confirmation e-mail that is sent to the 
customer after an order is placed on the website.    

Enter a company sales e-mail address into the From field.  This e-mail address will receive any 

responses from the customer if the customer replies to the confirmation e-mail.   

Enter an appropriate Subject line for the confirmation e-mail. 

Enter a miscellaneous message into the Message entry.   This message will appear after the 
main order information listing the items purchased and pricing. 

Enter the e-mail addresses into the Webmaster E-mail entry to send a CC to internal e-mails.   
These webmaster copies can be used to prompt the sales team about a web order.    Web orders 
can also be queried within EBMS.  Review the Processing Orders > Displaying and Printing New 
Orders section for more details on listing new orders within the EBMS software. 

Click on the Store Messages tab. 



Getting Started 

9 

The Login Message will appear when a customer logs into the system.   This message will not 
be displayed if a generic retail user is shopping the site without logging into the website.   Review 
the Configuring the Shopping Cart > Customer Login for more details on customer logins. 

Click OK to save the web group properties. 
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Creating Website Content 
Planning Your Website 

It is important to plan the product arrangement for an e-commerce website before entering folder 
templates and information as well as product organization. The ideal number of groups on a 
website is between 6 and 20 although less than 6 or more than 20 can be accommodated. 

Each one of these groups may contain subgroups.    The arrangement of product groups and web 
pages will be directly related to the organization of the inventory folders within EBMS.  Subgroups 
can vary from a few subgroups to dozens or even an hundred or more if necessary.    It is 
important to organize products in groups and subgroups that simplify the navigation process of 
finding products or groups of products.   For example the first level of product groups is shown 
below: 

  

Since the folders labeled Accessories, Computers, Hardware, Networks, Peripherals, and 
Printers are located on the first level of the folder tree, these folders will create the first level of 
product options within the e-commerce site as shown below.   
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Notice that not all the folder groups within the EBMS folder list are displayed on the web.   This is 
based on a Show on Web setting within the folder.  The www.EshComputer.com example shown 
above has the e-commerce product list menu attached to the Products menu option on the left 
side of the site.  The product menu is designed for each company to create a navigation menu 
that is tailored to the needs of each company.   

The Accessories group shown below has subgroups listing the difference accessories while the 
sub-group Printer Supplies has yet another level of product groups (folders) for each brand.    
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The Hardware folder group which is also a level one folder has a number of subfolders with the 
3

rd
 level folders grouping the type of Hard Drives and Memory.  Not all groups may contain sub-

folders.   Some of the first and second level folders may contain products while others are 
grouped in 3

rd
 or 4

th
 level folders.     
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The website is a bit easier to navigate if folder groups do not contain both products and sub 
folders although the system does allow this flexibility.   

 

The next page includes a chart to assist in planning the inventory structure. List the main product 
groups and their sub categories. 
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Note that the list is meant to be a guide and should not be restrictive.  

Inventory Structure 

1. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

i. ____________________________________ 

2. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

i. ____________________________________ 

3. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 
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h. ____________________________________ 

i. ____________________________________ 

4. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

i. ____________________________________ 

5. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

6. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 
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i. ____________________________________ 

7. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

i. ____________________________________ 

8. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 

i. ____________________________________ 

9. ____________________________________ 

a. ____________________________________ 

b. ____________________________________ 

c. ____________________________________ 

d. ____________________________________ 

e. ____________________________________ 

f. ____________________________________ 

g. ____________________________________ 

h. ____________________________________ 
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i. ____________________________________ 

 

Review the details within the Creating product Groups section to create these product groups on 
the web. 

After creating product group pages on the web, review the Listing Products section to add 
products to the website. 
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Creating Inventory Groups 

It is important to plan the product groups before proceeding with this section.   This section will 
explain the steps required to create web pages for each product group.  The website page 
settings are set within the Sales > Options > Inventory Folders tab as shown below. 

 

Click on the first folder group (example: Accessories) and click on the Properties button.  Click 
on the Website tab as shown below: 
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The Show folder on website option must be enabled to show this group on the website. 

 

Important note:   All parent folders must have the Show folder on website option enabled for the 
product group website to show.  For example the 3

rd
 level folder page will not be displayed on the 

web if the 1
st
 or 2

nd
 level folder has the Show folder on website option disabled.  This also 

includes the root folder labeled Products or Inventory.   The root folder normally does not require 
any settings except that the Show folder on website option is enabled.  

The Title is shown on the top of the web page.   If this entry is blank the folder name is used as 
the title.    

The Short Description is an optional description that is often displayed at the top of the product 
page.   This description should be limited to a paragraph or a few sentences. 

The Long Description may contain additional information and is not limited by the amount of 
data.   This section may include multiple paragraphs or other product links.    This description is 
also an optional entry.  Review the Links and Associations section for more details on product 
links. 

The Template drop down option determines the appearance of the page.   A number of template 
options are available within the EBMS software.    Review the Group Templates section for a list 
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of standard templates.   Custom templates can also be added to display specific information or 
customize the web page arrangement. 

The Thumbnail and Detail Image entries are graphics or photos that are displayed on the 
website and are arranged by the template.    These images should depict the contents of the 
folder.   Note that many templates display the Thumbnail image of all the subfolders and may not 
require any images on the root folder.   The Thumbnail image will be created from the Detail 
Image if the Thumbnail is required and the Thumbnail is left blank.    

For example the following steps were completed to create the following Printers webpage: 

1. Go to Inventory > Options and click on the Inventory Folders tab. 

 

2. Click on the root folder labeled Products, as shown in the example shown above, and 
click on the Properties button.   Click on the Website tab to show the following dialog: 
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a. Enable the Show folder on website option since it is the root folder.   This 
step is required so all sub-folders with the Show folder on website option 

enabled will be displayed on the web. 

b. Set the Template to a template such as /store/piclist3x4.asp.   This 
template will only be used if the products link is used on the website.    
Review the Group Templates section for more template options.    

c. Enter a Short Description or Long Description only if general product notes 
are desired.    No Thumbnail image is required on this dialog.  The Detail 
Image is not used at this level unless a template such as the itemList is 
used.  Review the Group Templates section for more information on group 
templates.    

d. Click on the OK button to return to the Inventory Folder list. 

3. Click on the Printers folder, Click on the Properties button, and click on the website tab 
as shown below: 
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This dialog will require more information than the root folder.  

a. Enable the Show folder on website so the printer page is created. 

b. The Title entry is blank so the system will use the folder label – Printers as 
the title. 

c. The Short Description gives the page some more information about the 
printers.   This description shows below the title – Printers in the website 

page shown in the following page: 

d. If a Long Description would be entered in this dialog, the description would 

be displayed below all the Icons.  

e. The template /store/piclist3x4 is selected so that the subgroups will be 
displayed with individual Thumbnails from the subfolders rather than the 
graphics within the printers dialog shown above.  The thumbnails are 
displayed 3 wide and up to 4 rows long.   

f. Click the OK button to return to the folder list. 

4. The Thumbnail images must be set within the individual subfolders – Fax Machines, 
HP Deskjets, HP Laserjet Printers, HP Office Jet Printers, etc.   The thumbnails for 
this page could also be created by the system if the Detail Image within each subfolder 
is properly created.   Review the Inserting Graphics into EBMS section for more details 
on inserting the Thumbnail or Detail Image graphics. 
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5. Update the website information by selecting Inventory > Update Website.   Review the 

Update Website Process section for more details on this step. 

6. The following website is created as a result of the setting described above.   

 

Page buttons will appear at the top and bottom of the web page if the number of product groups 
is greater than the space on the page.   The appearance of the website can be configured using a 
variety of options.   The flexibility of the EBMS e-commerce engine allows the user to personalize 
the shopping cart to match the site. 

Planning the relationship between the existing inventory folder arrangement and the product 
organization on the e-commerce site is very important.   The original inventory grouping within 
EBMS may need to be rearranged to fit the desired e-commerce store arrangement.     The E-
commerce module may also require the user to create more folders so that a large number of 
products are not located within a single folder.    Note that items or folders that are not listed on 
the web can be ignored when planning the e-commerce product arrangement.   

Continue with the Listing Products section for more details on adding items to the product groups. 
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Group Templates 

The Template setting within the Website tab of the inventory folder properties determines the 
way the product will be shown on the website.    Select a product group by selecting Inventory > 
Options and clicking on the Inventory Folder tab.   Select a folder, click on the Properties 
button, and click on the Website tab to open the following dialog: 

 

The template options are described below accompanied with sample website graphics. 
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Picklist3x4.asp 

 

The PickList?x?.asp templates are used to display folders or items within folders. 

This template displays the following contents from the selected folder settings: 

A. Displays the Title at the top of the page.  

B. Displays the Short Description below the title 

C. Displays the Long Description at the bottom of the webpage 

It displays the following contents from the sub-folder settings: 

1. Displays the sub-folder’s Thumbnails 3 columns wide and four rows long.   Multiple 

pages are created if the number of sub-folders is greater than 12. 
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2. The Title of each sub-folder is displayed under the thumbnail images.  

Additional pages can be accessed by clicking on the page number or clicking the Next link.   
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Listing Products 

This section will explain the steps required to add products to the e-commerce website.   We will 
continue with the example used within the Creating Inventory Groups section of selling printers 
online. The Printers group displays the subfolders labeled Fax machines, HP DeskJet, etc as 
shown below: 

 

Complete the following steps to add product information within a folder.   The HP DeskJet folder 
group that is shown above as a sub-group of the Printers folder will be used as the example in 

the following steps.   

1. Go to Inventory Folders tab within Sales > Options dialog from the main EBMS menu.   

The following dialog will appear: 
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2. Highlight the folder that contains the products that are to be listed on the website, click on 
the Properties button, and open the Website tab as shown below: 
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3. Enable the Show Folder on website so the content is displayed on the web. 

4. Enter the Title of the page or keep it blank to use the folder label.  

5. Enter a Short Description that is shown on the top of the product list.   This text is optional 
and can be kept blank if no information is needed above the product list. 

6. The Long Description is shown below the product list.   This text is also optional. 

7. Select the appropriate Template for the product group.   This setting will determine the 
way the products are listed on the website.   One of the common templates used for a 
folder with a list of products is the /store/singlelist.asp option.   The example shown 

below uses this template option. 
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8. Since the /singlelist.asp template lists individual product thumbnails and does not show 
any graphics for the entire group, the Detail Image can be ignored.   The Thumbnail is 
used within the Printer group so it is required.   See the printer group website example at 
the beginning of this section to see the Hp Deskjet group thumbnail displayed.  Click the 
OK button to save the option settings. 

Complete the following steps to enter the product information for each item or printer that is being 
sold on the website. 

9. Open an inventory item record that is located within HP DeskJet folder as shown below: 



E-Commerce 

32 

 

10. Click on the website tab of the inventory item as shown below: 
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11. Enable the Show item on website to display the item on the web.  Disable this option to 

remove the item from the site.    

12. Enable the Only show prices when customer logs in option only if the price is hidden 
unless a customer logs into the site before placing the order.   This option hides the price 
of all customers that browse the site without logging into the site with a user name and 
password.   This option can be ignored if the user is forced to log into the website.  Review 
the Configuring the Shopping Cart > Customer Login section for more details on customer 
login options. 

13. The Changes on web when out of stock option controls the affect of the inventory item 
on the website when the inventory stock is low.   This option should be set to No Change 

on all service and no count items since this option is based on the inventory stock.    

 Select the Mark out of stock option to place a temporarily out of stock message on 
the website by the item when the count is equal to or less than zero.   Note that this 
message will not appear until a web update has been done after the stock is sold.   
Review the Update Website Process section for details on uploading data to the 
web. 

 Select the Remove from web option to remove the item from the web till the count 

or stock is greater than zero.   
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 Set the option to No Change if the website is not affected by the number of items in 
stock. 

Tip:   Use the filter down method to change the Show item on Website, Only show 
prices when customer logs in, Changes on web when out of stock, and Template 
settings for an entire group of items.   Review the Features > Change Defaults, Filter 
Down, and Globally Change Data section within the main EBMS manual for more details 
on setting the defaults for items or changing a range of items at the same time. 

14. Enter the product label into the Title entry.   The system will use the first description on the 
General tab if the title entry is blank.  The Product Title is the bold text in the item list 

within the website example shown below. 

15. Enter an optional Short Description of the item.   The system will show the 2
nd

 description 
line found within the General tab if the Short Description is blank.  The Short Description 
is the text shown under the title in the website example shown below.  This text should not 
be lengthy. 

16. Enter an optional Long Description.  The system will use the 3
rd

 line of description within 
the General tab if the Long Description is blank.   The long description is displayed within 

the item details page of the product.    

17. Set the template option to /store/item.asp unless the item has multiple pictures, a 
serialized item, or other advanced feature.   Review the Advanced Features section of this 
manual for more details on other item templates. 

18. Insert a Detail Image of the product into the Detail Image block.  The Thumbnail image 
will be created from the detail image if the Thumbnail setting is blank.  Review the 
Inserting Graphics into EBMS section for more details on inserting the Thumbnail or 
Detail Image graphics. 

Review the Advanced Features > Displaying Component Options on the Web section for more 
details on the Component settings.   Click OK to save the settings for the inventory item. 

Repeat steps 10 – 18 for each inventory item that you wish to display on the website.  

19. Update the website after the folder group settings and inventory item settings are 
completed.   Select Inventory > Website Update from the EBMS menu to start the update 
process.   Review the Update Website Process section for more details on uploading 
information to the web. 

The following webpage was the result of the steps described above.    

 The text on the top of the page is derived from the Short Description within the HP 
Deskjet website folder properties.  See step #5. 

 The Thumbnail (Step 18), Title (Step 14), Short Description (Step 15), Inventory ID, 
and Pricing is listed for each item.  Review the Pricing Options section for more details 

on setting the pricing. 
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The Long Description (Step 16) and Detail Image (step 18) are found in the Item Details page.  

The following details web page is displayed if the user clicks on the item Details link on the list. 
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The Title and Short Description are displayed above the Detail Image. The Long Description, 
price, and product ID are located below the detailed image.   Review the Links and Associations 
section for more details on creating links within a description. 

Review the Configuring the Shopping Cart > Shopping Cart section for more details on the Add 
to Cart buttons. 

 

 

 

 



Creating Website Content 

37 

Inserting Graphics into EBMS 

Graphics and pictures can be inserted from a graphics file or imported directly from a camera or 
scanner.   It is recommended that all images be inserted from a designated computer that has 
Corel Paint Shop or Adobe Photoshop installed.  All images should be edited and sized, using 
Corel Paint Shop or Photoshop, before being inserted into EBMS.  

Complete the following steps to insert a graphics file into EBMS: 

1. Right click on the Thumbnail or Detail Image graphics outline and select Insert Object 

as shown below: 

a. The Detail image will be shown on your item detail page and will be the exact 
dimensions of the image inserted.  

b. The Thumbnail image will be shown on your item listing pages and will be the 
exact dimensions of the image inserted.  EBMS will automatically resize the 
detail image to create a thumbnail if the thumbnail field is left blank.  

 

2. Select either of the following two options. 

A. Create New to interface to camera or scanner software as shown below 

B. Create from File to import a graphics file from your computer.   Use the Browse 

button to locate the graphics file.    
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3. Click OK when finished.  
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Pricing Options 

The pricing on the website is generated from EBMS based on the price level within the customer.    
If the customer did not log into the website with a user name and password, the price level within 
the generic customer is used.  Review the Configuring the Shopping Cart > Creating a Generic 
Customer section for more details on creating the generic customer and price level. 

The customer’s designated price is displayed if the customer logs into the website.  Review the 
Configuring the Shopping Cart > Customer Login section for more details on customer log in 
procedures.   

The pricing on a website can be hidden by enabling the Only show prices when customers log 
in option within the inventory items a shown below. 

 

Complete the following steps to hide the pricing for all items on the website. 

1. Go to Inventory > Options and click on the Inventory folders tab.  
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2. Highlight the root folder as shown above, click on the Edit Defaults, and click on the 
Website tab as shown below: 
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3. Enable the Only show prices when customer logs in. 

4. Right click on the option and Filter Down option to all items.   Review the Features > 
Change Defaults, Filter Down Data, and Globally Change Data  section within the main 
EBMS manual for more details on changing an option for all inventory items. 

Pricing can be always be hidden if the website does not allow any customers to log in and the 
Only show prices when customer logs in option is enabled for all items. 

Bracketed pricing 
Special pricing such as bracketed pricing can be accomplished by using the optional Special 
Pricing module within EBMS.   Pricing based on volume will show on the details web page for the 
item.   Shown below is an example page from www.AlertAll.com: 
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.  

The bracketed pricing or volume pricing is displayed on a pricing table.   The appropriate unit 
price will be displayed on the shopping cart based on the volume.   Volume discounts can be 
determined based on the cost of the order rather than the quantity purchased.    

Review the Inventory > Special Pricing section of the EBMS documentation for more details on 
this module.    Contact your EBMS software representative to add the optional Special Pricing 
module to your software. 

Specials 
A promotional price can be displayed on the web with a Special star burst icon to alert the 
customer to product specials.   Promotional pricing is configured within the EBMS software using 
the same Special Pricing module as bracketed pricing.   The user can enter a price based on a 
time period.    

The website must be updated regularly to keep the special information updated.   The special will 
not be removed from the website until a web update is run after the special price time period has 
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passed.  Review the Inventory > Special Pricing section of the EBMS documentation for more 
details on promotional pricing. 
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Update Website Process 

Uploading data to the website requires a process that copies the information from the EBMS 
software to the website.   Since the information that is viewed by the customer on the website is 
not derived directly from the software in real time the Update Website process must be launched 
to keep the website information current. 

 

 

The EBMS update website procedure requires a high speed connect to the internet since the 
update is copying graphics and text to the website.   A digital connect of 128K upload speed or 
higher is required. 256K or higher is recommended. 

The Update Website process can be activated using either of the following methods: 

A. Updated manually 

1. Select Inventory > Update Website from the main EBMS menu. 

 

2. Select the Incremental button to copy only the changes to the website.   This 

method will decrease the amount of time required to complete the update. 
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3. Select the Complete option to update all information on the web.   This option 
should be used if an upload was aborted.   Always use this option if the incremental 
does not update changes that were made within the EBMS software. 

 

B. The upload can be automated by scheduling upload process with the MS Windows 
scheduler.   The data can be uploaded daily during off hours to minimize data access 
during business hours or can be schedule to update multiple times of the day to maintain 
inventory levels more accurately.  Contact an EBMS software technician for technical 
details on automating the web update process. 

The Website Update process should be launched regularly especially if inventory stock or 
special pricing affects the website.  Review the Listing Products section for more details on 
removing or marking items that are out of stock.  Review the Pricing Options section for details on 
listing promotional pricing. 

 

 





 

47 

Configuring the Shopping 
Cart 
Creating a Generic Customer 

Most retail e-commerce websites allow the user to purchase product without a membership or 
user account.   The EBMS e-commerce uses a generic customer setup to determine the shipping 
options, terms, and other details for these new customers.   A generic customer is required 
unless the website requires that a customer have an account before placing the order.   Required 
logins are used primarily for wholesale websites that require an account number to access the 
site.   

Complete the following steps to create a generic customer account. 

1. Create a customer record with a generic Customer Id such as WEBSITE a shown below.   
Review the Sales > Customers > Adding a New Customer section of the main 
documentation for detailed instructions on creating a new customer. 

 

2. Keep the contact information blank as shown above. 
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3. Set the Price Level for the standard web pricing.  The retail or list price is normally used.   
Create a new web price level if the pricing on the web is not equal to any standard price 
level.  Review the Inventory > Inventory Pricing > Inventory Pricing and Price levels section 
of the main EBMS manual for more details on creating price levels.  

4. Click on the Terms tab as shown below: 

 

5. Set the Due payment terms for a new customer.   This setting is normally set as Cash 
unless a new customer can place an order based on terms or the product is picked up at the 
store rather than shipped.   

6. Click OK to save the default customer settings. 

7. Select Sales > Options from the main EBMS menu and click on the Website tab as shown 

below: 
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8. Enter the generic customer id into the Web Customer entry.  

Orders that are placed using the generic customers will be downloaded from the web with the 
generic ID within the sales order.   The billing name and address will be placed within the sales 
order similar to a miscellaneous customer entry.   

The customer ID can be changed within the sales order either automatically or manually. 

Automatically 

a. Set the Customer Matching option to one of the following options: 

 E-mail Address – The system matches the e-mail address that is contained on the 
order with all the contact fields within the customer.   The contact fields do not require 
a specific label. 

 Name & Address – The system matches the name, city, state, and street address on 

the sales order with the information within the customer. 

The matching criterion is not case sensitive. 

b. Enable the Create new customer if no match option to automatically create a customer 
account if the Customer Matching criteria is not true.  The system will keep the sales 
order listed under the generic customer if this option is disabled.    The customer id must 
be created automatically if this option is enabled.  Review the Features > Creating IDs 
section of the main EBMS manual for more details on creating the customer ID 
automatically 
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The process to automatically create a new customer may result in redundant customer 
accounts.   A new account may be created rather than properly matched because of typos, 
spelling differences, or other minor differences.   2 accounts can b merged by opening the 
customer account, right clicking on the Customer id, and selecting Merge Customer 
Accounts.    Review the Sales > Customers > Merging Customers section within the EBMS 

software for more details on merging customers. 

Manually 

a. The Customer Matching option to None and disable the Create new customer if no 
match option. 

b. Open the sales order that was downloaded from the web. 

 

c. Select Edit > Change Customer from the sales order menu and the following dialog will 
open: 
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d. Enter the exiting Customer Id. 

e. The Change terms and freight… and Change billing and shipping customer… 

options should be disabled to maintain the information entered by the customer online.   

Click the Finish button to complete the change. 
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Customer Login 

Customer logins are required for the website to pre-qualify a customer.   This option is often used 
for customers who have special pricing or terms or if a company only sells wholesale and a 
dealer login is required.   The billing and shipping information is also updated for the customer if 
he logs into the website.   The customer’s user name and password must be entered within the 
customer record and uploaded before the user can use the account to log into the website.  

Complete the following steps to create a user name and password for a customer: 

1. Open a customer record within EBMS and click on the Website tab as shown below: 

 

2. Enable the Allow customer login option to upload customer information to the website.   

This option can be disabled to temporarily disable an account.  

3. Enter a Username. The customer’s e-mail address is often used for the user name.  

4. Enter the Password.  This field is not hidden unless the user security restricts this 
information.   Review the Getting Started > Security section of the main EBMS 
documentation for more details on restricting this field within EBMS. 

5. Enable the Force EBMS pricing option to override the website price with the current 
EBMS price when the sales order is inserted into EBMS.  Note that the customer would 
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receive the current EBMS pricing on the confirmation document that is e-mail to the 
customer from EBMS.    A discrepancy between the website price and the EBMS price 
would exist only if the website has not been updated since a price increase.   There are 
also a few advanced special pricing settings that are not reflected on the website.   
Review the Pricing Options section for more details. 

6. Enter a Message to customer that will appear when the user logs into the website.    
Complete the following steps to filter down a customer message to all customers or a 
group of customers: 

a. Go to Sales > Options and click on the Customer Folders tab. 

b. Highlight the root folder for all customers or a folder group and click on the Edit 
Defaults button. 

c. Click on the Website tab to enter the Customer message. 

d. Enter the Customer message and then filter down the message.   Review the 
Features > Change Defaults, Filter Down Data, and Globally Change Data section 
of the main EBMS documentation for more details on filtering down data. 

7. Select the appropriate web Group.   Review the Advanced Features > Multiple Web 

Groups  for details on this setting. 

Click OK to save settings. 

The user can log into the website by clicking on the login button within the navigation menu of 
the website. The Update Web process must be run before the new customer log in information 
can be used by the customer.   Review the Update Website Process section for more details. 

 

The facility to allow the user to request a user name and password can be added to a website 
and communicate to the EBMS user.  Contact an EBMS representative for more details on this 
option. 
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Shopping Cart 

The settings for the shopping cart must be completed before product can be sold on the website.   
The shopping cart is used to create orders within the e-commerce website and communicate the 
order to the EBMS software.   The shopping cart links within a web page vary based on the style 
of the site.     

 

The shopping car is normally a separate web page.  Click on any of the links to view the shopping 
cart page.   The most common method of adding items to the shopping cart is to view the item 
within the site and then click on the Add to Cart button as shown below: 
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Enter the quantity desired and click on the Add to Cart button.  This button is found on the 
product details page of every item and also on some template lists.  The Add to Cart button will 
open the shopping cart page  
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Items can be deleted from the shopping cart by changing the quantity to zero and clicking on the 
Update Cart button.   

Items can be added to the shopping cart by entering a part number and quantity at the bottom of 
the cart and clicking the Add to Cart button.    

The customer can click on the Continue Shopping button to return to the previous shopping 

page.    

The company’s shipping, payment, and information policies should be clearly posted on the 
website.   The user should be able to access the policies page from the check out page.     The 
policy page should include the following: 

 Shipping policies 

 Return policies 

 Credit card processing policies – The site should explain the secure payment process 
including SSL certification.  

 Information collection policies – Is the data used for any internal or external advertising 
purposes? 

 Any minimum orders or quantities should also be listed. 

 The policy page could also contain special warranty information. 

A general note entered within the EBMS software can be displayed on the shopping cart page.   
Complete the following steps to enter this note: 
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 Select Sales > Options from the main EBMS menu and click on the Website tab 

 Select a web group and click on the Properties button 

 Click on the Store Messages tab and enter the Shopping Cart Message.   

The Update Website Process must be launched before the note will appear on the shopping cart. 

Check out 
Click on the Check Out button on the shopping cart or on the website menu to purchase the 
products within the website.  The customer must enter the shipping location to calculate shipping.  
This information will default form the customer record if the customer logged into the site.  Review 
the Customer Login section for more details.  

 

The customer is required to enter the shipping address and click Continue. 
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The shipping options available to the customer are configured within the EBMS software.  It is 
important to have product weights and shipping methods setup properly before placing the e-
commerce site on-line.   Review the Shipping Options section for details on setting up the 
shipping options within the EBMS software. 

Click the Continue button to proceed. 

The Billing Information page of the shopping cart checkout will display all the items that are 
being purchased including state sales tax (if applicable) and shipping costs.  The user can select 
from the billing options available to them.   Normally the only payment option for a user that does 
not log into the website is a credit card payment option as shown below: 
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Review the Payment Options section for details in setting up additional payment options such as 
Cash On Delivery (COD) or Charged to Account. 

 

Note:   The credit card and billing information will not appear on this page if the Use 
Authorize.net form option is enabled in Website tab of File > System Options.   A separate 
Authorize.net button will appear for the user to access the Authorize.net form for security 
reasons.   Review the Payment Options section for more details on the Authorize.net settings. 
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 A fictitious credit card can be entered into the shopping cart to test the process.  Review the 
Testing the Shopping Cart for details on testing the shopping cart. 

Complete the following steps to enter credit card information to complete a cash sale: 

 Select the Credit Card Type and enter the Credit Card Number without spaces or 
dashes.   Enter the expiration date (MM/YY). 

 Enter the billing address.   This address must match the billing address of the credit 
card.   

A website must be contain a secure Socket Layer (SSL) certificate to collect credit card 
information in a secure manner.  Review the Payment Options section for more details on the 
SSL certificate. 

Enter an e-mail address that will receive the order confirmation e-mail.   A sample confirmation e-
mail is shown in the following page. 

The Notes or special instructions entered within the shopping cart will appear on the memo tab of 
the sales order within EBMS. 

Click on the Process Order button to complete the order.    The following page will appear after 

the checkout process is completed.   

 

 Click on the click here link to return to the e-commerce website or close the browser. 

 

The website order that has been placed by the user must be downloaded to the EBMS software.   
This can be done automatically or by selecting the Download Web Orders from the Sales menu 
within EBMS.    A confirmation will be e-mailed to the customer after the order is inserted into 
EBMS.   Review the Downloading an Order into EBMS and Sending a Confirmation section for 
more details. 

Continue with the Testing the Shopping Cart section for details on testing the shopping cart. 
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Shipping Options 

The shipping methods that are available within the e-commerce website must be setup within the 
EBMS software.   Go to Sales > Options and open the General tab.   

 

Refer to the Sales > Freight and Shipping Charges > Connecting directly to UPS WorldShip or 
FedEx section within the main documentation for details on creating UPS shipping methods as 
shown above. 

 

1. Click on the Web option of each Shipping Method that is available to the website 
customer.   Only the Shipping Methods that contain a check mark in the Web column 

will be available within the shopping cart.    

2.  Launch the web upload process to move shipping methods to the web.    
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Payment Options 

The payment options within an EBMS e-commerce are as follows: 

A. Credit card – cash payments 

B. Cash on Delivery (COD) – Order is processed as charged but the shipping carrier 
collects the payment. 

C. Charged to Account – Customer has terms. 

The following sections explain the setup steps required to configure payment options on the web.    
Review the following options thoroughly before launching the e-commerce website. 

The payment options are listed in a significant order based on the requirements of each option.  If 
a customer account is configured to allow options B or C than all the options above their selected 
options are always available as well.   All website users will be able to pay using option A – Credit 
card since the system verifies the credit card using a credit card gateway.     If the system allows 
the user to pay using option B then option A is also available.   If option C is available to the user 
than both the A and B options are always available.   

 

Credit card payments are verified and processed within the EBMS e-commerce system using the 
Authorize.net gateway.     A credit card merchant account must be obtained from the user’s bank 
or a merchant account salesperson.   Any merchant account that communicates with the 
Authorize.net gateway can be used within the EBMS e-commerce system.    Note that most 
banks require a separate merchant account for e-commerce transactions from a website than the 
merchant account used in a card present situation within a store or office.   Review the 
Certifications and Applications > Authorize.Net Application section at the end of the 
documentation for details on applying for the Authorize.Net gateway. 

The type of merchant account obtained by the user will determine which types of credit cards are 
available to be used on the e-commerce site.    Complete the following steps to configure EBMS 
to match the credit card types of the merchant account: 

1. Configure the Authorize.net settings by selecting File > System Options from the 
EBMS menu and clicking on the Website tab as shown below: 
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The Authorize.net Login ID must be obtained by logging into the Authorize.Net website.   
This ID should be changed periodically for security purposes.  Review the Authorize.Net 
Application section for details on obtaining or changing this ID.   

2. Select Sales > Options from the EBMS menu and click on the Website tab as shown 

below: 
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Enable the credit card type options that can be processed using the merchant account 
connected to the Authorize.Net gateway.   The check marks for all credit card types that 
can not be used on the site must be disabled (unchecked).   Please verify the credit card 
types that can be processed with the merchant account before proceeding. 

3. Set the terms within the customer to determine the payment options on the web. 

a. Open the customer record (Sales > Customers) and click on the Terms tab 
as shown below:   A generic customer record is used if the user does not log 
into the website.    Review the Creating a Generic Customer section for more 
details. 
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b. The Due setting determines the payment options on the website.   Select one 
of the following options by clicking on the option button to the right of the Due 

setting: 

i. Select Card Number ______________ Expires __/__ ID____ to 

require the customer to use a credit card for each purchase. 

ii. Use the Collect on delivery option to allow the user to choose 

between COD or a credit card payment. 

iii. Use any of the charge settings (Net ___ days, Due by __/__/__, or 
Due the __th day of the …) if the customer can choose between 
charge on account, collect on delivery, or cash payment via credit 
card. 

Do not use the Cash terms for internet customers. 

The terms of the generic customer MUST be set unless the customer is required 
to log into the website.   Repeat these steps to set the terms for all customers 
who log into the website using a login name.  Review the Customer Login section 
for more details on requiring a login.     
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Testing the Shopping Cart 

Complete the following steps to test the shopping cart without creating valid transactions. 

1. Select items from the store and click on the check out link within the website.  Review 
the Configuring the Shopping Cart > Shopping Cart section for details on the shopping 
cart. 

2. The payment options within the shopping cart can be tested using 3 different methods: 

a. Bypassing the Authorize.net credit card process completely by entering the 
following information into the payment page of the shopping cart. 

i. Enter 55555555555555 into the Credit Card Number entry. 

ii. Enter Test Order into the First Name entry 

b. Putting Authorize.net in test mode.   Log into the Authorize.Net website and 
click on the Account – Settings link.   Click on the Test Mode link and put the 
Authorize.Net service in test mode.   No transactions that are processed when 
Authorize.Net is in test mode will be processed.   Put Authroize.net in LIVE 
MODE before website is available to web users.   The credit card merchant 
account is not tested when Authorize.Net is in test mode.    Use option C to 
test merchant account. 

c. The only way to test the credit card merchant account is to process a live 
transaction.  Enter a valid credit card account for a small amount.    You can 
delete the order before the credit card is debited. 

3. Download the order as described in the Configuring the Shopping Cart > Shopping 
Cart section. 

4. Go into the default website customer, open the sales order that was created by the 
website and delete the sales order or invoice.   Deleting the invoice will not void the 
Authrorize.Net transaction.  If option c. is used then the Authorize.net transaction must 
be deleted within the Authorize.net website.  Note that this transaction will disappear 
after 30 days if the card is not captured. 

 

A website that communicates credit card information must contain an SSL certificate.  Review the 
following SSL Certificate Application details for more information. 
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Processing Orders 
Downloading an Order into EBMS and 
Sending a Confirmation 

Orders created with the online shipping cart must be downloaded into the EBMS software.    

 

 

This process can be accomplished using one of two methods: 

1. Manually launch download from the EBMS menu 

a. Select Sales > Download Web Orders from the EBMS menu.  Review the 
Displaying and Printing New Orders section for more details on reviewing orders 
after they are downloaded. 

 

2. Automatically download each time an order is placed.  Complete the following step to 
install the EWNetServer to the Windows network server:   These advanced setup steps 
should be completed by a computer technician or EBMS support representative. 

a. Add user in EBMS called ?WEBSITE?. Use this user in the ewnetserver 

setup. This will allow the user to identify if an order has been created 

by the web. 

b. Enter proper settings in System Options 

c. Enter proper settings in Sales Options  
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d. Install ewnetserver.exe service on main computer with the setup 

program 

e. Make sure the service runs with the windows profile that defines 

printers and other settings that you want for web orders. 

f.   Setup registry. (replace USERNAME, PASSWORD, CID)  

 Windows Registry Editor Version 5.00 

 [HKEY_LOCAL_MACHINE\SOFTWARE\EWNetService] 

 "ComOut"="1" 

 "Port"="55555" 

 "555"="c:\\progra~1\\ebms\\ebms.exe 

/url:\"ebms:dbscript?username=USERNAME&password=PASSWORD&company

id=CID&Servername=localhost&ShowUI=false&[PARAMS]\"" 

g.   Setup any reports and settings in EBMS. If you have warehousing, 

you must set the default warehouse. Note that the windows user 

profile that the service runs in is what is used for printer settings and 

other EBMS user settings when the order is downloaded. 

 

Orders are downloaded under the generic customer unless the customer logged into the website.  
Review the Configuring the Shopping Card > Creating a Generic Customer and Configuring the 
Shopping Cart > Customer Login section respectively for more details regarding the generic 
customer and customer login procedures. 

An e-mail confirmation will be sent to the customer after the sales order is created within EBMS.   
The confirmation will be sent to the e-mail address entered by the customer on the billing page of 
the shopping cart.  Note that the e-mail contains an Order Number that corresponds with the 

sales order / invoice number.   A sample e-mail confirmation is displayed below: 
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The From e-mail address is entered within the EBMS website options.  Complete the following 
steps to set the Web Confirmation E-mail options: 

1. Select Sales > Options from the main EBMS menu and click on the Website tab 

2. Select one of the web groups (example: Primary) and click on the Properties button.  

3. Click on the Web Confirmation E-mail as shown below. 
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The e-mail address within the From entry found in the Groups Properties dialog is display on 
the e-mail confirmation’s From address.   

The Subject will be copied to the e-mails subject line. 

The text within the Message box in the Group Properties will be added to the bottom of the 

confirmation e-mail. 

The e-mail confirmation will be carbon copied to the Webmaster E-mail address.   Enter a 

semicolon between multiple e-mail addresses. 

The sales order can be associated to an existing customer without requiring the customer to log 
in by setting the Customer Matching setting within the Website options.   Review the Creating a 
Generic Customer section for more details on configuring EBMS to change the customer ID 
automatically when an order is downloaded.    

A new customer account can be created by EBMS automatically rather than maintaining the 
generic customer ID.   Review the Creating a Generic Customer section for more details on 
creating new customer accounts. 

Review the next section - Displaying and Printing New Orders for details on querying web orders 
in a convenient list. 
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Displaying and Printing New Orders 

Web orders can be displayed in a convenient list using the batch processing dialog within EBMS.   
Launch this dialog by selecting Sales > Batch Processing from the main EBMS menu as shown 

below: 

 

Select the web sale query from the query options.    

Complete the following steps to create a website sales query: 

1. Click on the Queries button to open the query list. 

 

2. Click on the Add Query button to create a new query. 
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3. Enter a brief website sales query Id and click the OK button. 

 

4. Enter a Query Description. 

5. Website orders are queried by a logical field within the sales order.    The Customer 
Query and the S.O. Detail Query settings do not need to be set to include all 
customers and all sales order details.   Click on the Sales Order Query  button to set 
the query shown below: 

 

6. Select the Web_Sale in the Database Field options. 
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7. Set the Operator option to is true. 

8. Click the OK button to save.  The Value option and And/Or option can be ignored.    

9. Click the OK button on the Query Properties dialog to save the new website dialog. 

 

10. Highlight the website query and click on the Close button. 

 

Click on a sales order record and click View Sales Order to open a sales order. 

Sort the sales order list by clicking on the Sales Order column title or the sales order Date 
column title. 

Complete the following steps to print a pick sheet or sales order document for a batch of orders: 

1. Select the orders that you wish to print by clicking on the Process column.   Click on 
the Select All button to select all the sales orders. 

2. Click on the Print button and select a form.   Review the Reports > Print Button 
section within the main documentation for instructions on adding forms and reports to 
a print button. 
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Processing Credit Cards 

The credit card is not debited immediately when the customer places the order unless the Use 
Authorize.net form option is enabled in File > System Options – Website tab.  Review the 

Authorize.Net Application section for more details on this option. 

The credit card is verified at the time of the order and the money is held for a few days.   The 
exact time period that the monies are held (customer can not sue the funds for another purchase) 
depends on the bank policy.    The credit card authorization (required for credit card to be 
captured) will be held for 30 days after the order is placed.     

The actual debit of the credit card happens when the Sales > Capture Authorize.net 
Transactions process is launched from the main EBMS window.    This process will review any 
payment transactions with WEBSALE in the check number.   The user will receive an error if a 
payment has been processed using the WEBSALE Check Number and the authorize.net 

transaction does not exist.   

Capture Down Payments 
Process a down payment with WEBSALE in the Check Number field as shown below to capture 

the payment before the invoice is processed: 

 

Review the Sales > Customer Payments > Down Payment on an Invoice or Sales Order section 
of the main EBMS documentation. 

View Unsettled Authorize.net Transactions 
Complete the following steps to log into the Authorize.net website:   

1. Launch www.Authorize.net website 

2. Click on the Merchant Login link on the upper right corner of the site. 

3. Enter the company’s user name and password. Review the Authorize.Net Application 
section for details on logging into Authorize.net. 

Click on the Search – Unsettled Transactions link on the left side of the website. 

http://www.authorize.net/
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The transactions will show as unsettled until the credit card payments are captured. 

 

Note: Deleting the invoice will not void the Authrorize.Net transaction. This transaction will 
disappear after 30 days if the card is not captured. 

 

Capture Credit Card Payments 
Launch the Sales > Capture Authorize.net Transactions process from the main EBMS menu. 

 

Cards will be automatically be reauthorized if a back order is created or the previous authorization 
has expired.   The user will be prompted if a payment can not be authorized. 
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Technical Note:   The GLT->PrintedFlag option within the transaction is enabled when a capture 
is completed. 

 

Depositing Captured Payments into the Bank Account 
The capture process debits the credit card and deposits the monies into the checking account 
although the deposit must be recorded within EBMS.   The credit card payments must be 
selected individually by the user and deposited into the checking accounting to complete the 
deposit. Complete the following steps to record the deposit within EBMS. 

1. Log into Authorize.net to view the captured transactions.  Click on the Transaction 
Statistics link for the capture total or the Transaction Detail link to list individual 
transactions as shown below: 

 

2. Open the deposit window for the cash account that records the e-commerce 
transactions.  The cash account is recorded in the Web Cash Account entry within 
the Sales > Options – Website tab.  

3. Select each payment that has been processed by Authorize.net.  Use the Select All 
button to select all the transactions within the cash account.  This process is simplified 
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if the Authorize.net payments are recorded in a separate cash account.  These 
transactions are listed in the captured transactions list within Authorize.net.  See step 
#1.     

4. Click on the Deposit button within the deposit screen of EBMS and verify that the total 
deposit equals the total amount authorized by Authorize.net.   This total MUST match 
the total give in the Reports – Transaction Statistics found within the Authorize.net 

web page. 

Review the Sales > Customer Payments > Cash Accounts, Deposits, and Reconciling Cash 
section of the main manual for more details on processing deposits. 
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Frequently Asked Questions 

Images are missing or are incorrect for an item on my website:  

1. Run a "Complete Update" from EBMS > Inventory>>Update Website>>Complete 
Update  

2. Make sure image is being inserted into EBMS properly:  

a. Make sure images are inserted into EBMS on a computer using the Paint Shop 
Pro or Photo Shop software.   An approved software application must be 
installed on the computer that loads the software into EBMS for the graphics to 
display properly. 

3. Clear out temporary Internet Files:  

a. From MS Internet Explorer go: 

b. Tools>>Internet Options...>>Under: Temporary Internet Files>>Delete 
Files>>Check: Delete All Offline Content>>Click: ok  

c. Go to the page where the item picture(s) are incorrect, if not corrected try 
pressing CTRL+F5 to do a "Complete Refresh".  

I am not receiving Order Confirmation Emails:  

1. Check setup in EBMS under:  

a. Sales>>Options>>Web Confirmation E-Mail  

b. Make sure your email address is in either the From: or WebMaster E-Mail  

c. If someone might have changed either of the above fields recently, make 
sure they are correct then run a complete update.  

2. If your company is running an in house Mail Server or using Spam Blocking 
software have your Systems Administrator check for blacklisted or queued Emails.  

I am receiving duplicate Order Confirmation Emails:  

1. Check setup in EBMS under:  

a. Sales>>Options>>Web Confirmation E-Mail  

b. Make sure there are no duplicate email address in the From: or WebMaster 
E-Mail fields  

c. If someone might have changed either of the above fields recently, make 
sure they are correct then run a complete update.  

  

 

Orders are not coming down automatically into EBMS:  

1. Check setup in EBMS under: File>>System Options>>Website>>field:Ebms Server  

2. If you are running a firewall (Software and/or Hardware), MS ISA or another program 
that might control Internet Access: make sure port: 55555 is open and available for 
EBMS.  

3. Check to see if the EwNetService is Installed & running on your Server or local 
machine: 
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a. From Windows XP/2000 go: Start>>All Programs>>Administrative 
Tools>>Services look for "EwNetServer" under service name.  

 

I cannot login to my FTP account with Internet Explorer or 
Windows Explorer:  

1. Use an FTP program  

a. Internet Explorer and Windows Explorer are not consistent for ftp 
connections. 

b. Some Window's Updates or Security Patches may also hinder FTP features 
that you are using.  
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Advanced Features 
Identifying New Products 

New products can be highlighted within the e-commerce site automatically when products are 
added to inventory within EBMS.   Items can be highlighted in two ways: 

 A new icon can be displayed by the new product.  The type of icon is determined by 
the website designer and can not be changed within the EBMS software.   Contact the 
website designer to change the new products graphics.    

 A New products link located on the website can be selected to list all the new items. 
The web page link for the new product list is www.sitename/store/newproducts.asp. 

The amount of time that an inventory item is identified as new is set within the website options.   
Select Sales > Options from the main EBMS menu and click on the Website tab as shown 

below: 

 

Enter a zero value to disable the feature and not show any items as new items.   

All items with an Entry Date that is equal to or less than the number of days from the current date 
will be tagged as new items.   Open an inventory record and view the Entry Date setting within 
the General tab as shown below: 
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NOTE: The upload process must be launched to add new inventory items or remove the New 
icon from existing inventory items.   Review the Update Website Process section for more details 
on updating information on the website. 

New item shown on listing page: 

 

New item shown on detail  page: 
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Links and Associations 

Hyperlinks can be created within the short or long descriptions of an inventory item using HTML 
links and other code.   Html is a web programming coded used to create websites. HTML code 
should not be used within the title description or within the inventory items descriptions located on 
the general tab.    An HTML link can allow the user to refer the website customer to other 
products within the site. 

Html is entered into the short or long description in the inventory item to create a link. For 
example: 

<a href="http://www.eshcomputer.com"> Click here to view the complete traditional collection</a> 

Click here to view the complete traditional collection is the text that will be shown on the 
page.  The link, http://www.eshcomputer.com, is the location of the link. The gray highlighted text, 
<a href=> and </a>, is the html tags. 

Note: To find the correct location link, go to the page that will be linked to and copy the url or 
address in the Address field at the top of your internet browser. Paste the link within the quote 
marks of the html. For example: <a href"Paste Here">. 

Following is a link in the short description of an item: 

 

IMPORTANT NOTE: 

After any html is entered into a field that field will require all html and will not recognize the 
standard memo functions such as the end of paragraph marker (entered using the ENTER key 
within a standard memo). To start a new line in an html field enter the break tag ,<br>, at the end 
of the line. To start new paragraphs enter two break tags, <br><br>. 

 

Additional formatting, such as bold and italic, can be added using html code. Text can be made 
bold by enclosing the text in bold or italic tags.  For example <b>This text will be bold</b> or 
<i>This text is italic</i>. The <b> or <i> indicates the start of the text formatting.  The </b> or </i> 
indicates the end of the text formatting.  

http://www.eshcomputer.com/
http://www.eshcomputer.com/
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Multiple Web Groups 

The web group feature within the EBMS e-commerce system allows the user to restrict certain 
items from the site based on the user or process multiple websites using a common company 
within EBMS.    A web group identifies a specific group of products that are available when the 
customer logs into the website.    

Most users do not create multiple web groups.   Multiple web groups are used only if some 
customers log into the site or products available on the website are limited to all or some 
customers.  Review the Configuring the Shopping Cart > Customer Login for more details on 
customer login options and settings. 

 

Complete the following steps to create and configure multiple web groups: 

1. Select Sales > Options from the main EBMS menu and click on the Website tab as 
shown below: 

 

Notice that the default web group is shown.   The EBMS software is distributed with a group 
labeled primary. 

2. Click on the New button to create an additional web group. 
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3. Enter a New group name that describes the group of products that are being grouped 
using this setting. Click the OK button. 

4. Highlight the new web group and click on the Properties button to open the following 

dialog: 

 

5. Add the appropriate Shipping Method within the Shipping Methods tab.   All 
Shipping Methods must be created within EBMS before they can be selected within 
the web group properties.  Select Sales > Options from within the EBMS menu and 
create the Shipping Methods within the General tab. Review the Sales > Freight and 
Shipping Charges > Creating Shipping Methods within the main EBMS documentation 
for details on Shipping Methods.     

6. Enter the Web Confirmation E-mail settings within the Web Confirmation E-mail 
tab.   Review the Getting Started > Getting Started section for more details on these 
settings. 

7. Click on the Store Messages tab as shown below: 



Advanced Features 

87 

 

Review the Getting Started > Getting Started section for more details on the message 
settings 

8. Click on the Filter inventory items by query button to identify the inventory items that 

are included in the web group. 

 

9. Set the query that identifies the inventory items that are included in the web group.   
Use the following steps to include entire groups of inventory items since items can not 
be queried by an inventory folder. 

a. Filter down a short identifier within the inventory group for a folder or group of 
folders.  The Type field is often used for this purpose.   Multiple codes can be 
entered within the same Type field if an item or group of items is contained 
within multiple web groups.   Review the Features > Change Defaults, Filter 
Down Data, and Globally Change Data section within the main EBMS manual 
for more details on filtering down data.  

b. Set the Database Field and Operator as shown above.   Enter the group 
code that was entered into the type field in the Value entry of the query.    
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c. Click on the OK button to save the query.  Review the Features > Advanced 

Query Options within the main EBMS manual for details on creating a query. 

10. Complete the following steps to associate customers with the web groups: 

a. Open a customer record and click on the Website tab as shown below: 

 

b. Identify the web Group by selecting a web group from the drop down list.   
Repeat for each customer or change an entire group of customers by using 
the filter down option.   Review the Features > Change Defaults, Filter Down 
Data, and Globally Change Data section within the main EBMS manual for 
details on setting the Group option for an entire folder group of customers. 

 

Contact an EBMS support representative for more advanced instructions on creating multiple 
websites for a single company or restricting products for individual customers. 
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Certifications and 
Applications 
Authorize.Net Application 

The E-Commerce website and the EBMS software use the Authorize.net gateway to transfer 
monies from the customer’s credit card account to the merchant’s bank account. 

 

 

Complete the following steps to apply and setup an Authorize.net account: 

1. Print an Authorize.Net Setup form.  This form can be found at 
http://www.EagleBusinessSoftware.com.  Select Vertical Markets > E-Commerce. 
Select Authorize.net Registration Form under Forms. Print form and fill out the first 
five pages 

2. Fill out the Authorize.net application as described below: 

a. Page 1 - Fax Cover Sheet and Application Checklist – This page describes 

the Authorize.net fees.   

b. Page 2 – Payment Gateway Setup Form – Enter the company information.   
Step 2 on this page requires a signature to authorize Authorize.net to deduct 
the setup fee and the monthly fee directly from the bank account.    

i. Market Type - Circle the Card Not Present (CNP) E-Commerce 
option 

ii. Software used to Submit Transactions to Authorize.Net – Enter 
Eagle Business Management System. 

iii. Optional Services - Circle the No option for optional services if the 
additional services are not needed. 

http://www.eaglebusinesssoftware.com/
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c. Page 3 – Authorization for Single Direct payment – Enter the bank account 

information that is used to for the Authorize.net direct payment.   

d. Page 4 – Merchant Account Configuration Form – A card-not-resent 
merchant account must be setup to process credit cards on the website.   An 
existing account can be used if the company has an existing card-not-present 
merchant account.   Contact your bank or merchant account reseller to 
determine if the company must apply for a new merchant account.    

A new merchant account can be setup by a bank or by a merchant account 
reseller if the company has never accepted credit card payments.   Contact your 
bank or an EBMS software rep for merchant account referrals. 

The information on page 4 will be supplied by the merchant account reseller.   

e. Page 5 & 6 – This information does not need to be filled out or sent. Discard.  

3. Fax the 4 page application to the fax number shown on the top of page one.  Include a 
copy of a voided company check that matches the information on page 3 of the 
application. 

4. Authorize.net will respond with a user name and password that are used to log into 
Authorize.net securely. 

5. Log into www.Authorize.net by clicking on the Merchant Login located on the upper 

right corner of the site. 

 

 Note:  The Authorize.net website is subject to change and may appear different than the 
image shown above. 

6. Log into the site using the user name and password given by Authorize.net.   The 
merchant login procedure is used to review transactions or test the credit card 
process.    

7. Click on ACOUNT > Settings in the lower left side of the Authorize.net website as 

shown below: 

http://www.authorize.net/
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8. Configure the following account settings: 

 

a. Click on the Direct Repose link, set the Delimited Response and Default 
Field Separator as shown below, and click the Submit button: 
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b. Click on the Password-Required Mode link, disable the Require Password 
for ALL Transactions, and click on the Submit button. 

9. Select File > System Options and click on the Website tab to open the EBMS dialog 
shown below.  Complete the following steps to copy Authroize.Net settings from the 
Account > Settings page of the Authorize.Net website:  

a.  Click on the Security Settings> API Login and Transaction Key link within 
the Account > Settings page of Authorize.Net.   

 



Certifications and Applications 

93 

b. Enter the username and password that is obtained from Authorize.net when 
the application is approved.   Enter this information into the Website 
Username and Website Password  entries within EBMS as shown above.    

c. The Authorize.net Login ID and the Authorize.net Password should be kept 
blank for new Authorize.net setup configurations.   Some original 
configurations were configured using the Authorize.net Login ID and 
Authorize.net Password entries with the API ID and TS key blank.   DO NOT 

CHANGE THE ORIGINAL SETTINGS if the original configuration is used. 

d. Click on the API Login ID and Transaction Key link within the Authorize.net 

website.   This link is found within the Security Settings group as shown below:  

 

e. Enter the Authorize.net API ID and Authorize.net TS Key from the 
information generated from the API Login ID and Transaction Key process.    

The Authorize.net TS Key should be changed annually to maintain the extra 

security of the Authorize.net form.     

 

10. Authorize.net can be configured to handle a credit card in a more secure manner using 
the Authorize.net form.   This option causes the customer to go into an additional 
secure Authorize.net web page during checkout for security purposes.   The credit 
card number will not be communicated to EBMS if this option is enabled.    Complete 
the following steps only if the additional security is needed. 

a. Enable the Use Authorize.net form option within the EBMS software as 
shown above.  

b. Click on the Relay Response link within the Settings > Account page of the 
Authorize.Net website.   Enter the following URL within the web page. 
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11. Authorize.Net can be put in testing module by clicking on the Test Mode link on the 
website.  Test mode will allow you to submit credit card transactions which will be 
"validated" but then disregarded by Authorize.net.    

 

Authorize.net credit card transactions can be viewed or voided by clicking on the Search – 
Transactions or Unsettled Transactions link within the main Authorize.net website login page.   

 

Transactions can be credited manually by clicking on the Tools – Virtual Terminal link within the 
main Authorize.net login page. 
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SSL Certificate Application 

Secure Sockets Layer (SSL), are cryptographic protocols that provide secure communications 
on the Internet for such things as web browsing, e-mail, instant messaging and other data 
transfers.   The SSL protocol allows applications to communicate across a network in a way 
designed to prevent eavesdropping, tampering, and message forgery. SSL provides endpoint 
authentication and communications privacy over the Internet using cryptography. Typically, only 
the server is authenticated (i.e., its identity is ensured) while the client remains unauthenticated; 
this means that the end user (whether an individual or an application, such as a Web browser) 
can be sure with whom they are communicating.  

It is important that a site is SSL certified if the website is collecting credit card numbers.   The 
SSL certification used on most EBMS e-commerce sites is the GeoTrust QuickSSL certificate.   
The SSL certificate should display on your e-commerce shopping cart to ensure the customer 
that your site is safe and secure.   The GeoTrust QuickSSL uses a 128bit encryption code for 
shopping cart communications. 

Contact your EBMS customer service rep for more details on the SSL certificate. 

 

 

http://en.wikipedia.org/wiki/Cryptographic_protocol
http://en.wikipedia.org/wiki/Security
http://en.wikipedia.org/wiki/Internet
http://en.wikipedia.org/wiki/Cryptography
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