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Introduction 
Technical Support 

Welcome to the instructional manual for the Sales Person Commission module of Eagle Business 
Management System (EBMS).  Eagle Solutions is pleased to provide you with instructions and 
tips regarding the Windows version of EBMS.  In the sections following, explanations and 
examples of the available features in the Sales Person Commission module of Eagle Business 
Management System will be explained for optimal use of the System.  If you need to reach our 
staff for further help, contact us using the information below: 
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Overview 

 

The Salesperson Commission Management module within EBMS is a powerful tool to manage 
salespersons within an organization.  The system manages commissions based on an income 
group identified by a general ledger account or range of accounts.  Commission rates may vary 
by salesperson and/or income group.  The module gives the user the ability to calculate 
commissions on the gross or net sales.  Commission payments may be generated at the time of 
the sale or after the invoices are paid in full.  Grouping sales orders, Invoices, quotes, or 
customers by salesperson is a convenient managing tool for a sales force.   

 

Salesperson entries appear in the following forms when the salesperson commission module is 
present: 

• Terms tab of a customer 

• Header of the sales invoice – This entry field appears even when the Salesperson 
module is not present but the entry can not be validated.   

• General Info tab of the proposal or quote 

 

Commission reports can be generated from EBMS without the Salesperson module but rate 
percentages and commission amounts are not calculated by the system.       

 

The Salesperson Commission module creates general ledger transactions at the time the sales 
invoice is processed.   Review the Processing a Sales Invoice with Commissions section for 
general ledger transaction details.  
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Getting Started 
Adding New Salespersons 

The list of salespersons is accessed by selecting Sales > Options from the EBMS menu.   Click 
on the Salesperson tab as shown below: 

 

Click the New button to open the new salesperson dialog as shown below: 
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Enter the name and contact information for the salesperson.    

Note: The Name entry becomes the salesperson’s identifier rather than a separate ID.   This fact 
must be considered if the Default salesperson to user name option is enabled in the Sales > 
Options > Invoices and S.O.s tab as shown below: 
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The Default sales person to user name option should only be enabled if the salesperson also 
has a login account within the EBMS software.     If this option is enabled, the sales person’s 
Name should appear on the sales person dialog in the same syntax as the user’s EBMS login 
name.    Review the Processing a Sales Invoice with Commissions section for more details on 
how this option is used.     Review the Getting Started > Security > Creating Users and Assigning 
Rights within the main EBMS manual for more details on creating user accounts.   

 

Click the Finish button to save the salesperson record.  Click on the Properties button to view or 

change the salesperson’s information as shown below: 
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Continue with the following section to create commission rates.     
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Commission Rates 

The commission rates are created for each salesperson by opening the sales person record.   
Complete the following steps to create commission rates: 

1) Open the sales person’s record: 

a) Select Sales > Options from the EBMS menu. 

b) Click on the Salesperson tab, select a salesperson, and click the Properties button. 

c) Click on the Commissions tab to open the following list: 

 

2) Select a Commission G/L Account from the available general ledger accounts.   Continue 
with step 3 unless a commission account must be created.  Complete the following steps to 
create a Commissions G/L Account if no commission accounts are listed.    

a) Open the general ledger chart of accounts and click on Edit > New to launch the new 
account wizard.   Review the General ledger > Chart of Accounts > Adding General 
Ledger Accounts for more details on creating general ledger accounts. 
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b) Create a current liability account as shown below: 

 

c) Continue with the Department Code and Profit Center pages of the wizard.   The 
Department Code  will normally be set to zero unless departments or profit centers 

divide the accumulated commissions.   

d) Continue with the new account wizard to the Select a Classification page as shown 

below: 
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e) Select the classification labeled – Salesperson Commission.   This classification must 
be selected so the account is available within the Commission tab of the salesperson.   
Click the Finish button to complete the new liability account. 

3) Return to the salesperson record and click the New button located on the Commission tab. 
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4) Enter an Id and Description for the group of commissions. 

5) Enter the Sales Account Range.   All commissions within EBMS are calculated based on 
the sales general ledger account used within the sales invoice.    If the sales account falls 
within the Sales Account Range the commission is calculated for the sales person.     
Separate general ledger codes must be created for each group of sales that are sold based 
on different commission rates.   

6) The Expense Account is used to record the commission expense at the time of the sale.   
Enable the Use sales account department for expense account option if the department 
code of the expense account is copied from the sales general ledger department.     Disable 
the option to enter the 9-digit expense account.     Review the Processing a Sales Invoice 
with Commissions section for details on the commission G/L transactions that are created 
when an invoice is processed.   

7) The Commission can be Based On either the Gross amount of the sale or the Profit of 
the sale.  Select the Gross option if the salesperson’s commission is based on the gross 
amount of the sale, or select Profit to use the gross profit amount of the sale.     

8) Enter the commission rate within the Percent Commission table.    If a commission rate 
changes, add a new rate to the bottom of the list along with the Effective Date.    

9) Click the OK button to save.   Repeat steps 3 through 9 for each commission rate. 

Repeat steps 1 through 9 for each salesperson.   
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Viewing a Salesperson's Invoices or 
Proposals 

The Salesperson module is a powerful tool to organize, manage, and report sales based on 
individual salespersons.   Quotes, sales orders, and invoices are grouped by salesperson within 
convenient tabs similar to the sales tabs within customer records.   Open a salesperson record by 
clicking on Sales > Options > Salesperson tab > Properties button.    

Proposal 

Click on the Proposal tab to view the proposals associated by selected salesperson.    

 

The salesperson’s proposals can be sorted by proposal Date, Quote number, Customer id, or 
Next Contact.   Click on any column to change the sort order.      The status setting can be 
changed to filter proposals based on Status as shown below: 
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Select the All setting to view all proposals for the selected salesperson or Open to view the 
proposals that are open or active.    The closed proposals can be viewed by Accepted or Not 
Accepted settings.   Review the Processing Proposals > Proposal Status Settings  section within 
the proposal documentation for details on changing status settings within a proposal. 

Double click on the proposal line to open the document and make changes.  The salesperson 
setting is located within the General Info tab of the proposal.   The Next Contact date is located 
within the Contact Info tab.   

 

Invoice  

Click on the Invoice tab to view the invoices associated to the selected salesperson.    
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Change the Status setting to view only specific invoices.    The salesperson can monitor invoices 
that are not processed by changing the Status to Sales Orders.       

 

Review the Paying Commissions section for more details on reporting options.    A salesperson’s 
proposals or invoices can be printed using the reports includes in the system.   Go to File > 
Reports and click on the Sales > Salesperson folders for the salesperson report options. 
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Processing Commissions 
Processing a Sales Invoice with 
Commissions 

The salesperson setting is found on the header of the sales invoice.  Open a sales order or create 
a new invoice as shown below: 

 

The Salesperson entry can be defaulted using two different methods. 

a. Default the EBMS login user as the salesperson.    This method requires the Default 
Sales Person to user name option to be enabled.   This option is found by click on 
Sales > Options > Invoices and S.O.s tab as shown below: 
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The Default sales person to user name option should only be enabled if the 
salesperson also has a login account within the EBMS software.     If this option is 
enabled, the sales person’s Name should appear on the sales person dialog in the same 
syntax as the user’s EBMS login name.    Review the Getting Started > Security > 
Creating Users and Assigning Rights within the main EBMS manual for more details on 
creating user accounts.   

b. The 2
nd
 method will be used if the Default sales person to user name option is 

disabled and the Salesperson entry within the customer record is populated.    A 
default salesperson can be assigned to a customer by entering the Salesperson entry 
into the Terms tab of a customer.   Go to Sales > Customers and click on the Terms 
tab to view or change the Salesperson entry as shown below: 
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A sales person can be manually entered or selected by using the salesperson lookup list as 
shown below: 
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The commission is calculated for the salesperson at the time the invoice is processed.  The 
following commission transactions are created if the sales general ledger account is within the 
range of any commission records.    

General Ledger Account of Finished Good items   ____Debit / 
Credit 

The commission expense account for each detail line with commissions Debit 

     This expense account is entered within the commission rate record.    

The commission liability account entered in the salesperson record.  Credit 

     This liability account is entered within the Commissions tab of the salesperson 

record. 

Review the Commission Rates section for more details on entering the liability and 
expense general ledger accounts. 

 

The liability account should always be used when paying commissions that were calculated when 
the sales invoice was processed.   Review the  
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Paying Commissions 

Commissions can be paid to the salesperson immediately or paid at the time the customer pays 
the invoice in full.  Commissions are processed when the employee or other salesperson is paid.   
Complete the follow steps to process the commissions and pay the salesperson.   

1) Go to Sales > Options and click on the Salesperson tab.    The commission must be 

processed for each salesperson individually. 

2) Highlight the salesperson and click the Properties button to open the salesperson record.  
Click on the Commissions tab as shown below: 

 

3) Click on the Transactions button to view the commission list.   The system will prompt the 
user to post transactions if there are transactions that are not posted within the sales file.    
General ledger transactions must be posted before they are displayed on the transaction list 
displayed below: 
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4) Set the commission Payment Date on the top of the transaction dialog.    Only commission 
transactions from invoices dated on or before the Payment Date will be displayed on the 

list.   

5) Commission transactions should be selected and processed before the salesperson is paid.   
Select the transactions by clicking on the first column labeled Select.   Commissions should 
be paid to the salesperson a) immediately after the sale or b) after the customer pays the 
invoice in full. 

a) Click on the Select All button to select all the transactions.  This option will process the 

salesperson’s commission after the invoice is processed. 

b) Click on the Select Paid button to only select the commissions that were generated 
from sales invoices that are fully paid.   Note that the Select Paid button will not select 

the commissions from partially paid invoices.    

 

Voided Invoices and invoices that are unprocessed with show as a negative transaction.    
This feature will adjust the salesperson’s commission pay if the invoice is processed, 
commission is processed, and the invoice is un-processed and deleted. 

 

6) Commissions can be adjusted using either of the following 2 methods: 

a) Individual transactions can be adjusted by right clicking on the transaction and selected 
Adjust Commissions from the context menu.    
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Enter the adjusted commission amount and click OK.   

b) A group of transaction can be changed by clicking on the Adjust Commissions button 

on the bottom of the list.  The following adjustment dialog will appear: 

 

Enter the range of dates (Start Date and End Date) for the transactions that need to be 
adjusted.    Select the Commission Id of the transactions.    Enter the new Percent 
Commission and click the OK button to complete the changes.  

7) Click the Process button to process commissions when all the commissions are validated. 

 

8) Click the Next button to continue to the next wizard page. 
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9) Enter the commission payment Date and click the Finish button.    All the transactions are 
grouped using this payment date.   This date is required when commission reports are 
processed as shown below. 

10) Complete the following steps to generate a transaction report to give to the salesperson or 
management: 

a)  Go to File > Reports and open the Reports > Sales > Salesperson group as shown 

below: 

 

 

The reports that are marked with a red check mark require the commission payment date 
entered during the process.    

b) Select a report such as the Commission Detail for Salesperson. 
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The Commission Date is the date entered during the transaction process.   The Period 
Ending date is for reporting purposes only.     

 

Repeat the steps within this section for each salesperson.  The reporting steps may be done after 
the commission transactions are processed for all salespersons.   
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